So I had a problem where some files would not synch. I tried installing
and using the source browser, but of course it was designed for the 3.2
client - and it gives:

An unhandled exception has occured [blah]
Method not found: System.Uri

If I click details:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.MissingMethodException: Method not found: System.Uri
at StoreBrowser.Form1.Form1_Load(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Mes sage& m)
at System.Windows.Forms.ContainerControl.WndProc(Mess age& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.ControlNativeWindow.OnMessage (Message& m)
at System.Windows.Forms.ControlNativeWindow.WndProc(M essage& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg,
IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.2032
CodeBase: file:///c:/windows/
Assembly Version: 1.0.2159.30763
Win32 Version: 1.0.2159.30763
CodeBase: file:///C:/Program%20Files/iFolder/StoreBrowser.exe
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.2032
CodeBase: file:///c:/windows/assembly/gac/
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.2032
CodeBase: file:///c:/windows/assembly/gac/system/
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.2032
CodeBase: file:///c:/windows/assembly/gac/system.drawing/
Assembly Version: 1.4.6166.1
Win32 Version: 1.4.6166.1
CodeBase: file:///C:/Program%20Files/iFolder/web/bin/SimiasClient.DLL

************** JIT Debugging **************
To enable just in time (JIT) debugging, the config file for this
application or machine (machine.config) must have the
jitDebugging value set in the section.
The application must also be compiled with debugging

For example:

< jitDebugging="true" />

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the machine
rather than being handled by this dialog.

If I click continue, the program starts, but I get either a 404 error on
inputting the Linux server, or a lower level connection was closed error,
same on localhost.

So I can't debug which files are not synching. So I try file by file and
no luck. Now I have file conflicts etc. So I try pulling everything out of
the folder ... no luck - now 12 files aren't synchronized.

So I say, what the hell, I just remove the iFolder on both sides. Synch
it... Wait.

I try and recreate the iFolder - it tries to synch and then disappears
from the client.

Go to the admin console, still showing up on the server. I try to manually
delete it from the admin console. No good: Error: Cannot delete iFolder.

Any ideas? I'm going to try and delete the directory manually from the
Linux server, but no idea if that will help.