Home

Results 1 to 2 of 2

Thread: Error compiling simias (simias-event-client.c:413: parse error before `*')

  1. #1
    croy@infiniweb.ca NNTP User

    Error compiling simias (simias-event-client.c:413: parse error before `*')

    Hello,

    I downloaded the tarbal version of simias-1.2.5347.1. I ran "./configure"
    (no errors) and then "make". I got an error when I ran make (see below).

    gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-98)
    Linux RedHat 7.2
    Kernel: 2.4.32grs-bipiv-ipv4-32
    libc: glibc-2.2.4-31 (libc.so.6 compiled with gcc 2.96)

    any pointers would be appreciated.

    # make
    Making all in src
    make[1]: Entering directory `/home/src/simias-1.2.5347.1/src'
    Making all in SimiasClient
    make[2]: Entering directory `/home/src/simias-1.2.5347.1/src/SimiasClient'
    Making all in libsimias-event
    make[3]: Entering directory
    `/home/src/simias-1.2.5347.1/src/SimiasClient/libsimias-event'
    if /bin/sh ../../../libtool --tag=CC --mode=compile gcc -DPACKAGE_NAME=\"\"
    -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\"
    -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"simias\" -DVERSION=\"1.2\"
    -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1
    -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1
    -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -I. -I.
    `xml2-config --cflags` -MT libsimias_event_la-simias-event-client.lo -MD
    -MP -MF ".deps/libsimias_event_la-simias-event-client.Tpo" -c -o
    libsimias_event_la-simias-event-client.lo `test -f 'simias-event-client.c'
    || echo './'`simias-event-client.c; \
    then mv -f ".deps/libsimias_event_la-simias-event-client.Tpo"
    ".deps/libsimias_event_la-simias-event-client.Plo"; else rm -f
    ".deps/libsimias_event_la-simias-event-client.Tpo"; exit 1; fi
    gcc -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\"
    -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"simias\"
    -DVERSION=\"1.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1
    -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1
    -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1
    -I. -I. -I/usr/local/include/libxml2 -MT
    libsimias_event_la-simias-event-client.lo -MD -MP -MF
    ..deps/libsimias_event_la-simias-event-client.Tpo -c simias-event-client.c
    -fPIC -DPIC -o .libs/libsimias_event_la-simias-event-client.o
    simias-event-client.c: In function `sec_register':
    simias-event-client.c:413: parse error before `*'
    simias-event-client.c:415: `ec' undeclared (first use in this function)
    simias-event-client.c:415: (Each undeclared identifier is reported only once
    simias-event-client.c:415: for each function it appears in.)
    make[3]: *** [libsimias_event_la-simias-event-client.lo] Error 1
    make[3]: Leaving directory
    `/home/src/simias-1.2.5347.1/src/SimiasClient/libsimias-event'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/src/simias-1.2.5347.1/src/SimiasClient'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/src/simias-1.2.5347.1/src'
    make: *** [all-recursive] Error 1



  2. #2
    Automatic reply NNTP User

    Re: Error compiling simias (simias-event-client.c:413: parse error before `*')

    Croy,

    It appears that in the past few days you have not received a response to your
    posting. That concerns us, and has triggered this automated reply.

    Has your problem been resolved? If not, you might try one of the following options:

    - Do a search of our knowledgebase at http://support.novell.com/search/kb_index.jsp
    - Check all of the other support tools and options available at
    http://support.novell.com.
    - You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://support.novell.com/forums)

    Be sure to read the forum FAQ about what to expect in the way of responses:
    http://support.novell.com/forums/faq_general.html

    If this is a reply to a duplicate posting, please ignore and accept our apologies
    and rest assured we will issue a stern reprimand to our posting bot.

    Good luck!

    Your Novell Product Support Forums Team
    http://support.novell.com/forums/



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •