From looking through the earlier threads I see I am not alone in the
problem; but maybe someone has a line on new information.

Iprint was working perfectly up until we installed sp3 a week ago.
Now we
get the winsock 10110 error when we try to install a printer from the
web
interface. This is clearly a dns issue.

I noticed that the url for the printer install contains our server
name
instead of the ip address. I'm not sure if I noticed in the past
whether
the ip address was there or not; but I suspect it was the ip not the
server name.

I found if I add a line in the workstations hosts file mapping the
server
name to the server's ip, the printer installs without a problem.
Clearly
this indicates a dns problem; but moreso it brings to my mind the
question
as to why was the ip in the url changed to the server name all of a
sudden?

We no longer run our own dns servers, that is what our isp does (and
they
have some convoluted setup that makes just running a straight dns
server
locally a difficult task due to the necessity of public verses private

mappings) and to go around making additions to all the hosts files of
our
workstations is not a viable option.

Therefore, the question remains, how can we get the ip address to
appear
in the url instead of the server name?

I have tried messing with the ipaddress and dnsname switches for the
manager, but this does nothing. Different attempts include:

ndpsm .hs_ndps_manager.complab1.hs.solehi -ipaddress=172.29.192.51
ndpsm .hs_ndps_manager.complab1.hs.solehi -ipaddress=172.29.192.51
dnsname=
ndpsm .hs_ndps_manager.complab1.hs.solehi -dnsname=hs_complab1_srv

nothing has worked; and it is very frustrating. We cannot build our
images for the new school year and time is running out.

Any help would be much obliged.

Thanks.

--
Dann S. Washko
Lehigh Valley Linux Users Group
http://www.thelinuxlink.net
get slack (www.slackware.com) and get happy