After the Sasser virus came out, the Desktop folks applied a patch to the XP
Image - now, I don't exactly know what they did or how all that stuff works,
so I apologize about that. Anyway, now when a new XP computer gets spun up
with this new image, when the user goes to install an iPrint printer it
errors out with the following error:

Error message: iPrint Client - No printer driver has been associated with
this printer.
Error group: iPrint Client
Error code: 65550

If I login as an administrator, I am able to install iPrint printers just
fine (we have AllowUserPrinters = 1 in the iprint.ini file) and then the
users can use that printer.

Please note that I have tried to re-install the iPrint client multiple
times, and different versions (our org is on 2.02, and I installed 3.05 with
no success). It also does not matter which iPrint agent I try to install,
same error for all printers. And if I go to a computer that was spun up
from the image before Sasser, all printers work fine. These "old" computers
are currently patched for Sasser, so the actual patch isn't the problem,
more likely how we are implementing it in our image.

So what should I look for if an administrator CAN install a printer using
iPrint but a normal user cannot?


Matt Walkowiak