We started introducing Kyocera FS1010n printers ( IB-21 printserver ) to our
network and moving to iPrint/NDPS at the same time. We have one FS1010n
working through PSERVER.NLM ( on NW5.1SP6 ) for about a year and are quite
happy with it. Setting up another FS1010n ( TCP/IP only this time, no IPX
NetBEUI etc. ) as an iPrint printer on NW6.5SP1 server was a breeze, as well
as pushing it to workstations with Zenworks 4.0.1 ( clients are Win XP Pro
SP1 ).

Test set up worked Ok and first printer worked fine as well in production
for about a day, then just stalled in the end of the day with a queue full
of print jobs ( "queue" as seen in iManager and PCounter software that we
use ), job sizes are small ( 10-100KBs each ). Printer seems to be online
and "printing" ( indicating "printing job" ) but no jobs are coming through.
On the switch port I see numbers ( bytes Tx ) growing very slowly and no
errors. Telneting to the printer works fine, built-in webserver is a bit
sluggish at times but generally Ok. Restarting printserver doesn't help,
removing current job doesn't help. Occassionally in printer status in
iManager I see "LPR communication failed" or "SNMP communication failed" but
generally it's showing as "Printing". I don't believe this is a
communication issue as everything else on the same switch is working Ok (
there was a queue based HP printer on the same port just before working over
IPX for a couple of years ). I tried disabling "sleep" feature as well to no
avail. A few more iPrint/NDPS ( HP ) printers are working Ok through that
NW6.5 server / iPrint manager.

Any ideas about Kyocera printservers on Novell networks ? .. as they seem to
be quite different from Jetdirect. Any info is greatly appreciated. I am
going to try upgrading firmware next week but this printer is brand new