This is an excert from tid:

There are also general IP issues that inherently affect LPR printing.
The three common problems are:
1) missing or incorrect \etc\hosts file;
2) missing or incorrect \etc\resolv.cfg file;
3) missing or incorrect gateway designation.

These are all general IP issues that have to be understood and accounted
for in any IP configuration on NetWare, not just NDPS. The \etc\hosts
file needs to define at minimum the local host name. In addition, the
\etc\resolv.cfg is necessary if DNS is to be used. The default gateway
must be defined explicitly or locatable via the routing protocol
configuration in order to allow traffic to successfully route off the
local subnets.. wrote:

> Greets,
> Hopefully this is a quick question, and I'm missing something REALLY
> obvious ... but I'm going nuts and I figured I'd ask ...
> We're implementing NW65/sp2 with the full NDPS/iPrint solution and
> utilising the NDPSGW (since the HPGW is no longer supported by HP) ... so
> off I go, connect a HP LaserJet 4100/5n/2100tn/etc printer to the
> network, DHCP enabled w/ DDNS updates, printer's hostname is "prn-test-
> 01" and it dutifully registers onto the network (as confirmed by the
> config sheet and nslookup).
> So, I head into iMangler, create printer, follow the bouncing ball and
> out comes an NDPS print object ... with an LPR error.
> Go in, restart the object - no joy.
> So, look up the gateway configuration, and from reading a few TIDs,
> discover it's set up incorrectly. So, after reading a few more TID's and
> forum postings, I correct it to what I think it should be looking like:
> ... but now I get:
> Printer State: Gateway Not Bound to Printer Agent
> ...
> I've tried setting up 3 other HP's - all with the same result. In case it
> was the dynamic DNS as an issue, I bound the printer to an IP address -
> no joy either.
> What the prairie-dog am I missing?
> All thoughts appreciated - even those declaring me a doofus.
> Taiss.