I'm running into problems getting secure iPrint printing working for the
Macintosh. I'm running a Netware 6.5 SP5 server. I've been running secure
iPrint for Windows users for a while and it works fine. I uploaded the PPD
files from my Windows computer, associated the appropriate file with the
appropriate printer, and then browsed to the iPrint map I made of our
building from a Mac OS X 10.3 laptop (I'm aware of the CUPS/SSL problems
with Mac OS X 10.4). I successfully installed the iPrint client, restarted
Firefox, and then browsed to one of the printers on the printer map. I
clicked on the link to load the printer, it prompted me for my credentials,
and I loaded it. I should note that all the printing URLs are https and not
ipp, as the secure printing for ipp didn't come until after I set this up
initially. However, when I try to print anything the print job is sent to
CUPS but just sits there as "printing." It won't print the document, it
doesn't seem to time out, and it doesn't prompt for additional
authentication. I tried rebooting the laptop and that didn't fix it. I
tried installing the Foomatic filters and ESP Ghostscript as detailed on
page 40 of the iPrint manual but that didn't fix it.

What's wrong and what do I need to do to fix it? I've tried searching
Google Groups and Novell TIDs but haven't found the solution.