When I set this up several months ago, everything worked fine
installing and printing to printers inside the firewall from the
outside. It's used infrequently, but when I tried to install printers
today from outside, I received a "Winsock 10060 - Connection has timed
out." error message.

I don't remember, but I think I've installed SP5 (from SP3) since it
worked last time. Also, an updated iPrint client has been deployed
since it was working. I've ensured that port 80 and 631 are opened up
through the firewall (we're not using SSL). I've looked at all the
TIDs, and nothing appears to address this problem.

The configuration is:
Netware 6.5 SP5
iPrint Client v4.16

I've performed a packet trace and found the difference between the
internal (working) and external (not working) scenarios boils down to
the external connections always generate an IPP RESPONSE [Malformed
Packet] reply. The contents of this packet is below. The strange
thing, and perhaps the source of the problem, is the "LOCATION" line
refers to the private (internal) IP address of the iPrint server, which
would not be accessible from the outside. Of course, if this is the
case, something with the new iPrint client or SP5 has changed. That
LOCATION LINE may only be an identifier, which if that is the case, has
no effect on the problem.

Any thoughts?

================================================== =
Source Destination Protocol Info
response[Malformed Packet]

Frame 6 (674 bytes on wire, 674 bytes captured)
Ethernet II, Src: Netgear_cd:91:3e (00:09:5b:cd:91:3e), Dst:
Intel_8b:88:05 (00:03:47:8b:88:05)
Internet Protocol, Src: XX.XX.XX.135 (XX.XX.XX.135), Dst:
Transmission Control Protocol, Src Port: 631 (631), Dst Port: 3734
(3734), Seq: 1, Ack: 942, Len: 620
Hypertext Transfer Protocol
HTTP/1.1 301 Moved Permanently\r\n
Request Version: HTTP/1.1
Response Code: 301
Date: Thu, 22 Jun 2006 19:21:54 GMT\r\n
Server: Apache/2.0.54 (NETWARE) mod_jk/1.2.14\r\n
Location: ipp://\r\n
Content-Length: 335\r\n
Keep-Alive: timeout=15, max=100\r\n
Connection: Keep-Alive\r\n
Content-Type: text/html; charset=iso-8859-1\r\n
Internet Printing Protocol
Version: 60.33
Status-code: Unknown (0x444f)
Request ID: 1129601360
[Malformed Packet: IPP]
================================================== ===