I have a similar issue when I switched the user's zen user policy login
from (DLU)local workstation to (no DLU) Microsoft Active Directory.

If I switch the user back to DLU login, problem goes away.

I also notice, when you goto Settings --> Printers and Faxes, the status
of those IPP printers shows "Openning" for about 5 seconds before going
to "Ready".

The question is, what's the difference between logging into the domain
versus local workstation? other than generated a new user profile.

I'm puzzled on why? Is there a Windows Fix for such a symtom?


Noam Erlichman wrote:

> I'm having a very weird and mostly consistent problem in my iPrint
> deployment:
> The time it takes to switch between printers is up to 40 seconds,
> during which the application freezes. The symptom is worst if
> switching to a HP DeskJet printer. Switch to a HP LaserJet driver
> takes shorter, but still could take up to 10 seconds.
> Done some traces via sniffer - and i see that the iPrint is trying to
> resolve the printer name via all sorts of different ways: DNS, WINS -
> and only after some kind of timeout expires will it switch.
> The stations affected are the ones with NW Client 32 on them
> (Win9x/NT/2000/XP). If i remove the Novell client from the station, it
> works fast.
> The only thing even remotely related to this issue i found said to try
> and change the short name, recreate the printers on the server & use
> the new NIPP 2.02 (that is in the NW6sp4 - just out of beta).
> Has anyone else seen anything like this slowness?
> p.s replacing the DNS server (that had problems) to a new fresh
> installed on (Win2K based) solved a browsing issue with the drives and
> servers, but did nothing to solve the iPrint problem.