Currently in production, we're running iPrint on a Netware 6 sp5 server (manager 3.01i, broker 3.0.9.) We have around 135 printers set up in the system, and are planning on moving up to NetWare 6.5 over the summer to enable iPrint support for OS X, as well as to provide better support for PCounter (with NW6, it doesn't work with iPrint printers - you have to do NDPS printers, but in NW 6.5, you can do iPrint printers, so our students would be able to install lab printers on their personal computers and still be able to be audited by the campus print management software.)

Anyhow, here's the dilemma. In order to start preparing for this upgrade (since I've heard about problems in the user forums with SP6 for 6.5,) I built my test environment server and configured it exactly the same way as our production environment, and built a VirtualPC client running the same way as our typical workstations do. Currently, our iPrint clients all point to the short printer name, the DNS name of the print server, rather than the IP address (since it's an internal IP address.) On iManager, the IP address URL's are all like ipp://172.16.x.y/ipp/printername, but when we point the client to install using the DNS name, it works fine. So, I set up the test environment and test VM in that same way - worked fine. After I did the upgrade to NW 6.5 however, and logged into the workstation, it said that "one or more printers were renamed by the administrator, please wait while we update the information." And then, it came back with an error that the printer had an invalid name, and would be deleted. I looked at the console, and everything was still named the exact same and appeared to be functioning properly. So, I looked in iManager, and it still showed the Accepted iPrint URL as being ipp://172.16.x.y/ipp/printername. When I tried to reinstall the printer using that exact name however, it worked fine. This provides several problems for us:

1.) We would have to manually reinstall every printer on campus. (500+ workstations.)
a.) During the meantime, no one would be able to print. Whoops!
2.) Off-campus iPrint printing would no longer work, since it would be trying to print to a nonroutable IP address, instead of the DNS name.
3.) It's just darned annoying!

Does anyone have any insight into why this was broken in 6.5, and if there's a way to add an additional accepted iPrint URL? This is a huge show-stopper for us.
Thanks in advance!

Chris Myers
CCNA, A+, Thawte WOT Notary, AMX Certified Designer & Installer
User Support Specialist, Millikin University IT Dept
(217) 362-6488
People use duct tape to fix everything . . . God used nails