I'm seeing this "interesting" behaviour:

1. Upload a fresh clean ppd driver for Mac/Linux clients to the Broker
Success! Driver is available to assign to a Printer Agent!

2. Assign the driver to a Printer Agent

3. From a Linux or Mac client, select the Printer Agent from the iPrint url
Success! the driver is installed and the local printer is created!

4. Do a test print
Success! (Glossing over some other issues for another time) Paper comes
out of the printer!

Realize that the ppd has incorrect default settings, like A4 instead of
Letter as default page type. So...

5. Modify the ppd and re-add it to the Broker
Success! Driver file replaced. I checked the newly created archive/zip
file in the Broker's driver directory (on NetWare)

6. Remove the Printer from the host (Linux or Mac)

7. Re-select the Printer Agent from the iprint web page
Success (sort of, almost)! The driver is downloaded!

8. Test Print
Failure! The driver is still set to use A4 as the default page type.

I examined the ppd downloaded to the host and found that it DID not
contain the modified setting, yet the ppd stored on the server by the
Broker DOES contain the modified ppd.

Clearly there is disconnect between the Broker driver repository and the
NDPSM/Printer Agent delivering the driver. So the NDPS/iPrint manager must
be using a driver file from some other location. Sure enough, Novell
docuements this in a TID from Jan 2005. That is 2 years ago. It is TID
1008966 for those that want to read it. The directory is sys:/ndps/ipp/...

So anyways, this is a BUG, I mean it has really bugged me for several days
now trying to figure out why my updated ppd's were not getting downloaded
to the clients. And it makes no sense to me why you would move a file from
point A on a server to point B and call that a 'cache'. How is that
supposed to actually improve anything? It might even make it worse as the
sys: volume may not be as fast a file system/hard disk drive as the volume
you put the Broker on. Argh.

Anyways, the temporary solution (untested just yet, but I will test this
tomorrow when I am the office) appears to be the deletion of the cache
files on sys:/ndps/ipp. But that is a very weak solution since it needs to
be repeated, manually. Ugh. So finally we come to my two pleas (please):

1. Novell Eng. Please remove the caching 'feature' from iprint.
2. Anyone: any idea on how to stop the caching feature? That would be


Ron Neilly

PS. Now I have to eat crow because it looks like the Mac is not at fault.

Using Opera's revolutionary e-mail client: http://www.opera.com/mail/