I have had similar issues. Encrypted authentication is working now, though I am not exactly sure why. The most recent patch we have had applied was edir862sp3, which you may want to try. Have you tried
setting the simple passwords manually?

Josh

Dirk wrote:
> Hi folks,
>
> I've experienced something quite strange :
>
> We're seeing problems with mac users and simple password

authentication
> using encrypted authentication. Using the cleartext option,

everything
> works fine.
>
> So we just installed a standalone NW6 SP2 server out of the box,

started
> AFPTCP and tried to map a volume from one mac. Works fine.
> Next step was to upgrade NICISDI to 242.98 (SP2 comes with v2.01).

Then
> ran sdidiag and revoked / regenerated the key and got a new key with

168
> bit, whereas the key from the initial installation was a 56 bit key.


> After upgrading the key to 168 bit, the encrypted authentication

fails.
>
> Any ideas ? Is MAC OS 9.2 not capable of triple DES encryption ?
> Is there a patch on the MAC side ?
> Any hints are welcome...
>
> /cu
> Dirk
>