Just a (long) warning to anyone with Mac clients and using the Novell
Consolidation Utility to migrate data from one server to another (theMigration Wizard or SMS-compliant backup will likely have the same
and how I got past the problem:

I've just used the Novell Server Consolidation Utility (from the
NetWare 6.5
CD) to migrate 2 volumes from a NetWare 6.0 server (SP3 with patches,
volumes) to a single NSS volume on a NetWare 6.5 server (with NSS &
eDirectory patches).

All went reasonably well (the ~90 GB copy dropped out a few times, but
restarted it and it appeared to complete OK), until I tried connecting
a Mac OS X (v10.2.8) machine. I was surprised that I could no longer
the Data volume (I could before the data migration).
When I connected to the server (instead of directly mounting the
volume), I
found that the volume name was not as I had entered in AFPVol.cfg,
it was one of the old server's volume names!
I tried AFPStop.ncf and AFPStrt.ncf, expecting that the presence of
correct name in AFPVol.cfg along with the RenameFromNWVolName
parameter in
AFPStrt.ncf would fix it - it did not!

I tried all sorts of things to clear the old name, including deleting
hidden files/folders at the root of the volume (e.g.
TheVolumeSettingsFolder), rebuilding the desktop (which was taking
all without success.

The Novell Support Knowledgebase didn't help.

Finally I tried installing the old "NetWare Client for Mac OS" serversupport NLMs from NetWare 4.11.
Loading NWCMacC.nlm didn't help - it didn't recongnise the NSS volumes
having Mac name space.
Then I unloaded AFPTCP, and tried MacFile.nlm - and presto - using
command the problem was fixed:

MacFile Volume Name For <NetWareVolumeName>=<DesiredMacVolumeName>

This command may have worked too (although I haven't tried):

MacFile Remove Volume Name For <NetWareVolumeName>

Wherever the hell the Mac volume name's stored, I don't know.

All I can think of is perhaps the Mac volume name was originally
written on
the old server volume by MacFile/NWCMacC when the old server was
NetWare 5
and the NetWare Client for Mac OS (8.x) was being used.

It's kind of disappointing that Novell don't really include this
functionality in AFPTCP, but claim to.
Has anyone else has run into this problem?