Has anyone seen anything like this?

I have a NetWare 6.0 SP5 running CIFS with domain authentication.
Unicode support is Enabled (although I have tried without it as well).
Domain is M$ Server 2003, native mode.
Security on the domain has been dumbed-down to allow LM and NTLMv1
WINS servers have all required entries (for DC and NW CIFS server)

I also have a NetWare 6.5 sp2 server running CIFS with domain auth.

The problem is that mapping to a share on the 6.5 servers works, but
it fails on NetWare 6.0. When attempting to access the URL from a
WinXP workstation, the system simply times out with a "network name no
longer avilable" (after about 3-4 minutes of no output at all)

Previous troubleshooting steps:
-Ran NMAS Monitor to watch for auth problems on the 6.0 server... No
attempt to connect is ever registered! (There was a thread on this
earlier without any resolution).
-Tried auth in local authenticaiton mode... also fails!
-Tried resetting simple password on test account... fails!
-Removed and reinstalled lsmcifs from the eDir tree, no change.
-Reinstalled CIFS and NMAS on all servers in the tree... no change.
-Ran SDIDIAG to repair key problems... problems were detected and
repaired, but no change in status of the problem.
-Ran DSRepair with schema rebuild just for fun... no help.

I suspect that there are some major differences between NW 6.5 and 6.0
in CIFS implementation, but I really do not want to upgrade my cluster
to 6.5 at this time... it has been stable for a year now after major
growing pains, and I would like to leave it alone for a bit.

I know that is a lot to chew on... any thoughts?

-Greg Mackinnon
CIT Client Services
University of Vermont