We took our first big production file server to nw65sp2 over the
weekend. Along with the many Windows users, this server supports 60+
Mac users. afptcp.nlm worked swimmingly using nw6sp4 on the box (IBM
235 single 2.6 ghz xeon with 4 GB RAM).

However, this morning afptcp.nlm has died twice. It got so slow that
the Finder on the Macs (including the one in my office plugged into the
same gigabit switch) would lock up for 80-90 seconds between clicks.

The first time it happened I was able to "afpstop.ncf" and
"afpstrt.ncf" successfully. This solved the speed problem and everyone
was able to get back in.

The second time by the time I noticed speed issues afptcp.nlm had
abended. "afpstop.ncf" has now hung the server console and I'll be
rebooting over lunch (a fairly big deal for a server with so many

I'm going to try backrevving to the afptcp.nlm from nw6sp4 to see if it
will solve my issues.

Has anyone else seen problems like this?

I'm running afptcp.nlm successfully on a couple other nw65sp2 servers
that don't have as many Mac users.