Hi, All
I don't know if this is the right forum for this, but I don't know where
else to put this.

We are running a NetWare 5.1sp6 server on a Compaq ML530 server with 3GB
RAM, eDirectory 8.7. This server holds the Master replica of the root
partition. We are running NFSSERV.NLM version 15.04b, NFSADMIN.NLM version
15.01a and NFS.NAM version 9.28. The entire Vol1 of this server is mounted
as a Unix drive on our RedHat Enterprise 9 server.

The Linux server copies some text files to a directory on this server -
these are then picked up by Cognos Powerplay, which is running on a server
with Windows 2003 installed. After manipulating the data, this machine
copies files to the NetWare server, which are then available to be sent out
as reports to the end users.

The problem we are experiencing is that at times the copy fails, both in the
automated system and when things are run manually, due to the files being
locked on the NW server - yet when we check in Monitor, there is no lock
listed for the file, and no connection has the file open. In addition to
this, files created manually on the volume as test files by the program
administrators are also listed as locked. The files cannot be deleted or
moved - however sometimes they can be renamed, but this is not consistent.
These problems seem to arise with different client OSs and different
versions of the Novell client.

we have tried the following:
1) Disabled file caching on the client.
2) Enabled level 2 Oplocks on the server
3) Rebooting the client/server and trying to access the files again.
4) changing network settings on the server NIC, the client NIC and the
Switch (Cisco 2900)
4) Upgrading to a later version of Cognos PowerPlay (now on version 7.1)
5) Doing a fresh install of the latest version of Cognos PowerPlay on a
brand new, higher specced server.

Nothing seems to have made any difference.

We were wondering whether perhaps NFS might have something to do with
locking up these files - anyone else had a similar experience?

Any help would be greatly appreciated - feel free to email me directly if
you would like.