I posted this in the Netware 6.x Administration Tools Forum --- but it was
suggested that maybe I should post in this forum.
Hope this is correct. Thanks.
We're having drop box issues with Netware 6.5 (SP1a), with afptcp patch.

We've created a folder (ie: drop box) on a Netware 6.5 server, giving users
'create' rights only to the folder. We don't want the users to be able to
see whats in the folder --- only copy new files to the folder.

Seems pretty easy, and its worked in the past with our older Netware
servers, but on Netware 6.5 its not quite working as expected. ???

The problem on Netware 6.5 servers: (we've tested this out on more than one
server with the same results)

On OS X workstations with only the (create) rights on the Netware 'drop
box' --- It will copy a file, or an empty folder to the drop box with no
problem. However, if the folder being copied contains files -- it just
copies the folder itself (no files) then comes up with the error "Sorry, the
operation could not be completed because an unexpected error occurred (Error
code -50)."

Note: As a test, we assigned (create and write) rights to the 'drop box'
and now all the files and folders (empty or not) will copy --- but the users
can now see the folders in the drop box. (They can't see any files --- just
the folder structure). This isn't desirable since they don't want any
folders displayed, even if the files in them don't show up.)

On Windows XP Clients --- It copied *nearly* all of our test files/folders
except some older DOS application files. When we tried to copy a file
called 3c90x.com dated 1999 --- it instantly created a 0 byte file in the
'drop box' on the server, then tried to overwrite the file, couldn't because
only 'create' rights were granted, and told us 'access denied', leaving the
0 byte file in the drop box when the copy failed. It had no issues with
the majority of the other files/folders being copied - just some older DOS
application files. ??

Anyone have any clues???