I am testing NW6.5 SP2 on a single server and have created a DFS Junction
and CIFS enabled it inc. Ops Lock and Unicode. I have created 3 volumes

I have created a DFS junction under DATA of DATA1 and DATA2.

It works fine using a client with Novell Client 4.9sp2e. I can map a drive
and create/delete as normal.

It fails using a std WinXP SP1 client. I can create delete etc. at the data
level using CIFS acess but can't get to DATA1 or DATA2.
I can get to them directly \\servername\data1 or \\servername\data2 but not
when I try to get to it using \\servername\data and then change to data1
I can't get it to map to \\servername\data\data1 either

Can anyone tell me if this actually works in NW6.5SP2

I have read the thread below and can't tell if James did get it working.

I have tried the same and failed to get it to work. I have tried on 3
separate servers 2 were NW6.5 SP2 and 1 was NW 6.5 SP1b

have been working on this as well and I can get the Novell client based
Map to work with the DFS Share and go to the sub-directories/volumes.
But when I try to get to it using a non-Novell client based Win XP Pro - I
get the errors you were getting. I can connect to the CIFS share of each
volume, but I get the problem when I try to get to the sub-directory/volume
using CIFS.
I have made sure the unicode and dfs support under CIFS is enabled and
confirmed it when CIFSSTRT loads.

Did you get it working with a non-Novell client based Win XP Pro machine?