We have multiple PCs with Novell clients accessing a NW65 SP2 CIFS share
through a Citrix-published GIS application that resides on a Win2K SP4
server running Citrix MetaFrame Presentation 3.0 server. The Win2K
server does not have a Novell client. The GIS application opens
mulitiple shared mdb files (25-30 files totaling 150MB) when it loads.

Here is the CIFS INFO:
CITYGIS1:cifs info
CIFSNLM Operating Parameters:
Server - "CITYGIS1-W"
Comment - ""
Authentication - "Local"
Workgroup - "WORKGROUP"
Oplocks - Disabled
DFS - Disabled
Unicode - Enabled
Domain Add-on - Disabled
Share point - "sys2$"
Share point - "amanda"

Here is the CIFS NLM info:
CITYGIS1:m cifs*
Loaded from [SYS:SYSTEM\]
(Address Space = OS)
CIFS Semantic Agent (Build 451 MP)
Version 3.22 June 11, 2004
Copyright 1987-2003 Novell, Inc. All Rights Reserved.

Loaded from [SYS:SYSTEM\]
(Address Space = OS)
NMAS Proxy for CIFS (Build 130 MP)
Version 3.22 May 24, 2004
Copyright 1987-2003 Novell, Inc. All Rights Reserved.

Sometimes the GIS application loads the mdb files in 10-15 seconds,
sometimes it takes 2-3 minutes, sometimes they take 20+ minutes. I have
not been able to pinpoint what is causing the disparity in file loading

I've tried the following scenarios:
- CIFS oplocks enabled/disabled
- local/shared mdb files
- NCP and TCPIP UNC names (haven't tried NETBIOS names, yet)

I just read on the forum about needing NETBIOS UNC names when the PC does
not have a Novell client. Could this be the cause of my problems? What
else would cause intermittent hanging like this? Does a newer version of
CIFS NLMs solve this issue?