I tried to copy a folder from my Mac's desktop to a NSS volume on the
server. The copy process failed after a few files. They were .pkg and
..dmg files (package and disk image files).

Next I tried to delete the entire folder, but was unable to do so
because the folder was not empty. I was unable to delete the files
inside that folder from a Mac - it said they were in use, even though
they were not.

I was finally able to delete them using TOOLBOX. However, I cannot
delete the folder nor any subfolders I created inside that folder. I
tried deleting them from a Mac, a PC (using Client32 and CIFS), TOOLBOX,
Compaq File Manager (CPQFM.NLM), ConsoleOne, iManager - no luck.

I keep getting an error message (if I get one) saying the directory is
not empty or that I may have insufficient rights. The directory,
however, IS empty.

I also tried copying a folder with the exact same name (plus a file
inside that folder) to the server. There was the usual message saying
"The folder already exists. Would you like to replace...". I had it
replace the existing folder on the server with the one from my (PC)
desktop. I was then able to see the file that was inside that folder.

Next I tried to delete the folder with the file inside, but I got an
error message saying the directory "is not empty". yet, upon looking
inside that directory, I found it to be empty.

What is going on????

BTW, I applied the latest AFPTCP patch, the latest TCPIP patch and the
latest NSS patch. I also ran DSREPAIR, had the volume trustee rights
checked, ran a NSS /PoolVerify... Nothing seems to be able to make that
stubborn folder go away.

How can I get rid of that folder???