I saw another post in this forum on the following, but my question is
where do you set the set the "Delay Rebind Try in seconds" to 0 on the
client. the post follows

We are having some success in authenticating with LDAP from MAC OS 10.3

to Netware 6.5 edir 8.7.3 using TLS.
But the LDAP trace on the server shows errors in connecting before a
proper connection is finally established.Here is an exert from the LDAP

trace -

New TLS connection 0xa65ea380 from 128.232.254.6:49221, monitor =
0x1aa,
index
19
Monitor 0x1aa initiating TLS handshake on connection 0x8f9df000
Monitor 0x1aa initiating TLS handshake on connection 0xa65ea380
(128.232.254.6:49221)(0x0000:0*x00) DoTLSHandshake on connection
0xa65ea380
(128.232.254.6:49220)(0x0000:0*x00) DoTLSHandshake on connection
0x8f9df000
(128.232.254.6:49220)(0x0000:0*x00) TLS accept failure 5 on connection

0x8f9df00
, setting err = -5875. Error stack:
(128.232.254.6:49220)(0x0000:0*x00) TLS handshake failed on connection

0x8f9df00
, err = -5875
15:16:19
Server closing connection 0x8f9df000, socket error = -5875
Connection 0x8f9df000 closed
(128.232.254.6:49221)(0x0000:0*x00) Completed TLS handshake on
connection
0xa65e


Does anyone have any idea what is causing the errors above, namely -
'TLS accept failure 5 on connection 0x8f9df00, setting err = -5875'.
?

Charles



reits...@denison.edu Jun 1 2004, 8:55 am show options

Newsgroups: novell.support.native-file-access
From: reits...@denison.edu - Find messages by this author
Date: Tue, 01 Jun 2004 15:55:19 GMT
Local: Tues, Jun 1 2004 8:55 am
Subject: Mac TLS connection errors
Reply to Author | Forward | Print | Individual Message | Show original
| Report Abuse

I put the notes on our experience at macosxlabs.org in their Wiki under

Authentication and Directory Services:
http://webcrossing.macosxlabs.*org/w...t.1@.*26bf4c24

The two changes we needed to make were:
1) set the "Delay Rebind Try in seconds" to 0 on the client
2) use the SSL CertificateIP rather than the SSL CertificateDNS on the
LDAP
server