Here it is in a nutshell:

When saving a file over itself (just hitting 'save' in the app) on a
NW65 server with a Mac OSX client, the Date Modified field doesn't
update - but the size does change.

This is a big problem for our studio artists who rely on accurate dates
and times for versioning.

More details:

I have tried on 10.3.9 and 10.4.6. Servers are 65 sp5, sp5 + NSSupdate,
sp4. (Our NW60 server works fine). I have tried different accounts (user
and administrator). I open the file from the mounted volume (Illustrator
CS2, Excel 2004, textedit) make a small change and hit 'save'.
Watching the folder at this point I see the temp file created (with the
correct date) then (I'm guessing) it copies the temp over the original,
or deletes the original and renames the temp - either way, the file size
changes, but the old date remains. Copying the file to my desktop, doing
a small change and saving it back to the desktop changes the date - now
if I copy this file via the finder to the volume the date is updated

So I have read through the posts here and tried the post sp5 nss patch,
changed the Level 2 Oplocks enabled to off, and client file caching
enabled to off, on one of the servers with no change. Time is correct
and synchronized across the servers and workstations I tested.

I am now unsure where to proceed. It seems pretty definite that it is a
Novell issue, but where it lies is unclear to me, any help, advice or
direction is appreciated. I'm stuck!