I ran into something strange today. I brought down my Netware 6.5.5 file
server after a JRE update. When I brought
it back up no Mac users could access their data (I don't attribute this
to the JRE update). The errors they received indicated a bad
username/password, locked account, etc., and to contact the server
admin. I did an NMAS REFRESHPOLICY on the server and the problem
persisted. I did a DSTRACE of Mac authentication attempts to that server
and the results indicated the NMAS login sequence was not available on
the three servers in my root partition replica ring...which I thought was
weird because that login method is installed in edir and worked before
the reboot. My file server is not in that replica ring - it's not even in
that partition (though the servers holding replicas of the root partition
also hold replicas of the partition the file server IS in). So, I ran
an NMAS REFRESHPOLICY on the master of the root partition and then Mac
users could log in again. Anyone have a chance to explain what actually
happened here - what was actually broken? I've rebooted that server a
few times in the past and never ran into this.