We're testing a config in a test lab before rolling it out. We have aprimary server and a second backup server. Our plan is to have DNS on
and DHCP ready on the second if the first fails.

We're testing procedures if the primary server fails altogether and
everything is bought up on the secondary one. Everything works now on
secondary server, including DDNS, after we change the server
assignments on
the DHCP subnets and change the Designated Primary on the DNS domain
to be
the second server.

However we can't get reverse lookup to work on the IN-ADDR.ARPA zone,although it worked fine withe the first server config.

The IN-ADDR.ARPA zone is called 31.10.IN-ADDR.ARPA. The servers
addresses on
the isolated network are (primary server which is down) and (secondary server running DHCP and DNS). The IN-ADDR zone
primary with both servers as Authoritative. We changed the DDNS server
the IN-ADDR zone to be the second server. In the IN-ADDR zone's SOA
the second server has been set as the Zone Master. The email address
root.31.10.IN-ADDR.ARPA. All modules reloaded on the server.

The DHCP subnet options/other options has both servers IP addresses
for dns, although the 'down' server islisted first. And when we try an

nslookup from either the workstation or the secondary server it gives
error saying:

(Secondary server error looking up
" query failed. DNS request timeout. Default
server name cannot be resolved."

(Workstn looking up
"DNS request timeout. Default servers are not available"

We can make the secondary server reverse lookup work by changing the
resolv.cfg so the secondary server's NAMESERVER entry is listed FIRST,
this isn't a fix: we can't change all servers and reinitialize system
on the
fly. And we still have no fix for the workstations.

Any help gratefully (nay desperately) received,

Steve Law