I have just recently configured DNS on my Netware 6, sp4 servers.

I have two servers setup for load balancing and have started to migrate my
users off of the external DNS service to the internal. The problem is
that the server(s) lock up - and have ever since I loaded names.nlm

The primary server is a compaq dl360 with 2Gb ram. It only runs my
Groupwise primary domain and hold the NDS master. There are no users
logging into this machine, nor are there any other applications running on
it.
The primary DNS server is as shown here:
Processor 0 on line
Intel(R) Xeon(TM) CPU 2.80GHz
Speed 2786 MHZ, Family 15, Model 2, Stepping 9
Feature flags 00004400:BFEBFBFF, CPUID: GenuineIntel
L1 cache 20K Bytes, , L2 cache: 512K Bytes
Instruction TLB: 64 entries, Data TLB: 64 entries
Logical Processors per Physical Processor: 2
Processor Initial APIC ID: 6
Processor 1 on line..... Stop processor
Intel(R) Xeon(TM) CPU 2.80GHz
Speed 2786 MHZ, Family 15, Model 2, Stepping 9
Feature flags 00004400:BFEBFBFF, CPUID: GenuineIntel
L1 cache 20K Bytes, , L2 cache: 512K Bytes
Instruction TLB: 64 entries, Data TLB: 64 entries
Logical Processors per Physical Processor: 2
Processor Initial APIC ID: 7


The secondary server is shown here:
Processor 0 on line
Intel Pentium III processor
Speed 550 MHZ, Family 6, Model 7, Stepping 3
Feature flags 0387FBFF, CPUID: GenuineIntel
L1 cache 32K Bytes, , L2 cache: 512K Bytes
Instruction TLB: 68 entries, Data TLB: 68 entries

Processor 1 on line..... Stop processor
Intel Pentium III processor
Speed 550 MHZ, Family 6, Model 7, Stepping 3
Feature flags 0387FBFF, CPUID: GenuineIntel
L1 cache 32K Bytes, , L2 cache: 512K Bytes
Instruction TLB: 68 entries, Data TLB: 68 entries

This server runs the Groupwise secondary domain and acts as the secondary
DNS server.

I have the DNS configured as follows:

10.100.100.10 (10.100.100.10.IN-ADDR.ARPA - Dynamic DNS Primary
accesshorizon.com - Dynamic DNS Primary
HORIZON - Dynamic DNS Primary
Mail.accesshorizon.com - Dynamic DNS Primary

Under 10.100.100.10 I have:
@
corp2.horizon (this is the primary DNS server)
Mail2.accesshorizon.com (this is the secondary DNS server)

Under accesshorizon.com I have:
@
172.16.0.2 (A record)
CORP2.Horizon
Mail3.accesshorizon.com
Secure
172.16.0.2 A Record (internal number for us to access internet Banking
server)

WWW
172.16.0.0 A Record
HORIZON
@
CORP2.HORIZON (resource record type NS Authoritative Server
CORP2.RootServerInfo (resource record type NS Authoritative Server
MAIL.HORIZON - (resource record type MX)
Mail2.accesshorizon.com - recource record type NS Authoritative Server

Then I have all of my internal servers entered as domain names and an A
record for each one with the IP address

MAIL.ACCESSHORIZON.COM
@
10.100.100.19 - Resource Record Type A (this is the GWIA)
CORP2.HORIZON
MAIL3.ACCESSHORIZON.COM

RootServerInfo
corp2.horizon (and lots of other entries that must be generated
automatically)

On the two actual DNS objects that are located in the bottom part of the
DNS/DHCP mgmt console are the two servers:

DNS_CORP2
DNS_MAIL3

Both servers show the zones as described above.
Both servers have our external ISP IP's in the forwarding list.

So, that's my configuration. Can anyone assist me as to why named.nlm is
freezing up my servers, and then of course no DNS takes place.

The version of named.nlm I'm running is 5.12.05 dated December 9, 2003.

Thanks in advance - I know this is a book, but I just wanted to make sure
I documented everything in the configuration.

Cheryl