Having problem with dns servers giving up, all external requests.
after a while, between 1-12 hours. The only way to get it to work is
unload load of named.
All this started just before x-mas, and before that the servers has
worked like a charm for month. And before that the where nw51.sp6 with
a similar problem like this.
Both servers a authoritative for my domains. and one or the other is
primary for the domains.
Both have read/write of root partition, where dns/dhcp resides.
No errors found in edir.

Configurations of the server is like this:

Server 1: nw65sp2, edir 8.7.3.3, tcp 6.57.09 (24 sept.-04)
named 6.03.06 (14 dec-04), this server also runnning dhcpsrvr 3.13.03
(3 dec-03)

Server 2: nw65sp2, edir 8.7.3.3, tcp 6.67.03, named 6.03.06

Non of the server is running anything else.

I have upgraded both servers to latest named and edir after the
problems started (if it works, don't fix it, especially just before a
long weekend) and tryied with the latest beta tcp on server 1.

Did have an overlock of RootServerInfo, and there where some small
problems, my servers auth. for rootserverinfo domain, must have come
with the migration, and a object under rootserverinfo, called
rootserverinfo, with my servers in it, this also from the migration I
guess. Removed these things, and added forward servers, which we
havent been using before.
Now the dns is alive for (last run) 12 hours.

has been running in -dl 1 -s for some time now to see whenever it
stops
Here are the server screens when the servers has stopped.

Server 1:
<snip>
info: Found correct number of counts in header
info: client 194.47.25.8#2390: Novell Dynamic Update : Query received
info: Failed in getting question name : Checking for StartStop /
Dynamic update query
info: Found correct number of counts in header
info: client 194.47.25.8#2391: Novell Dynamic Update : Query received
info: Starting the dynamic reconfiguration
info: Dynamic reconfiguration completed.
info: Failed in getting question name : Checking for StartStop /
Dynamic update query
info: Found correct number of counts in header
info: client 194.47.25.8#2392: Novell Dynamic Update : Query received
info: Failed in getting question name : Checking for StartStop /
Dynamic update query
info: Found correct number of counts in header
info: client 194.47.25.8#2393: Novell Dynamic Update : Query received
info: Failed in getting question name : Checking for StartStop /
Dynamic update query
info: Found correct number of counts in header
info: client 194.47.25.8#2394: Novell Dynamic Update : Query received
<end of screen>

server 2 mostly stops with a screen of dynamic update

Looks like it has something to do with the dynamic (re)configuration.

Also has done some small tweaks, just to see if it has any impact.
On both servers, under the advanced tab:
max-cache-TTL set down to 2 days, and
transfer format set to one-answer.
Didn't see any diffrence.

Please help someone....

Paul

----------------------------
Paul Thurn