We currently have a problem and that the DHCP is not passing the Directory
Agent to the local workstations.

Current Configuration is.

Netware 5.1 SP 3 installed.

We are using a unscoped at this stage.

The DHCP has been setup with option 78 having the IP addresses of the two DA
machines and has been set to mandatory.

The following is a client workstation slpinfo

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : wahs.health.nsw.gov.au
IP Address. . . . . . . . . . . . : 10.60.81.100
Subnet Mask . . . . . . . . . . . : 255.255.240.0
Default Gateway . . . . . . . . . : 10.60.92.230

C:\>slpinfo /a


************************************************** ***
*** Novell Client for Windows NT ***
*** Service Location Diagnostics ***
************************************************** ***

SLP Version: 1.0
SLP Start Time: 8:50:14am 1/13/2005
Last I/O: 10:08:01am 1/13/2005
Total Packets: Out: 181 In:
Total Bytes: Out: 14511 In:


SLP Operational Parameters Values
------------------------------- ------------
Static Scopes NO
Static Directory Agents NO
Active Discovery YES
Use Broadcast for SLP Multicast NO
Use DHCP for SLP YES
SLP Maximum Transmission Unit 1400 bytes
SLP Multicast Radius 32 hops


SLP Timers Values
------------------------------------- ------------
Give Up on Requests to SAs 15 seconds
Close Idle TCP Connections 5 minutes
Cache SLP Replies 1 minutes
SLP Default Registration Lifetime 10800 seconds
Wait Before Giving Up on DA 5 seconds
Wait Before Registering on Passive DA 1-2 seconds


Scope List Source(s)
---------------------------------------- ------------
<unscoped>


DA IP Address Source(s) State Version Local Interface Scope(s)
--------------- --------- ----- ------- --------------- ---------------

<No Directory Agents>



Local Interface 10.60.81.100
---------------------------------
Operational State: UP
Operating Mode(s): MCAST
SA/UA Scopes: <unscoped>
Last I/O: 10:08:01am 1/13/2005
Total Packets: Out: 58 In:
Total Bytes: Out: 3961 In:
Last Addr Out: 224.0.1.22
Last Addr In: 0.0.0.0


Local Interface 10.60.81.100
---------------------------------
Operational State: UP
Operating Mode(s): MCAST
SA/UA Scopes: <unscoped>
Last I/O: 9:40:49am 1/13/2005
Total Packets: Out: 123 In:
Total Bytes: Out: 10550 In:
Last Addr Out: 224.0.1.22
Last Addr In: 0.0.0.0

As you can see it is not picking up any of the Directory Agents. Can
someone please help ?

Email me at dcampbell@iinet.net.au or campbed@wahs.nsw.gov.au

Thanks

David