Some weeks ago I deleted our Netware 6.5 Sp2 DNS server's rootserverinfo
zone after a dsrepair procedure caused some random unknown objects in the
tree, including some in the rootserverinfo object, and dns for external
internet histnames stopped working.
Last night I recreated it using the standard import template supplied by
Brad in previous posts, but it still would not resolve internet hostnames.
Although internal names in it's own database worked fine deleting the newly
recreated zone fixed the problem.

I'm not sure how to fix this problem.

One possiblity: there are forwarding addresses set for both our dns servers
(which are both primaries). The first entry is the external dns server of
our internet provider. I noticed that trying to troubleshoot that if I tried
to invoked this external dns server to perform an nslookup on www.google.com
(with the command "nslookup www.google.com xx.xx.xx.xx" then I got a failure
message which seemed to be based on the fact that dns couldn't resolve the
ip address of the external dns server to a hostname. Does dns *need* to be
able to resolve the hostname of a dns server in order to use it? Why can't
it just query it as an ip address? Does this mean I have to put in an A
record or nameserver record for all forwarding entries?
Once I deleted the rootserverinfo zone I can use the external dns server in
this way as it has no trouble resolving it's hostname.

I tried to take a log trace but was under too much pressure to fix the
problem and screwed up the command. I'll see if I can get one tonight by
recreating the problem.

Our network is fairly simple: one main dns zone, two primaries (the second
being for fault-tolerance), no zone transfers or anything like that.
NW65SP2, named.nlm is 6.03.06 14th Dec 2004.

Any help appreciated,

Steve Law