I've got what appears to be a very odd problem that I've so far been unable
to resolve.

I'm trying to send mail from a RedHat Linux 9 box to our Groupwise server
via sendmail. The Sendmail maillog files always lists the status as DNS:
Host unknown

Doing a nslookup from windows has turned up a very interesting result. The
MX records, while initially appearing, disapear after a while.

To reproduce (addresses altered to hide real values)
On the netware server, unload named.nlm, then reload it
On Windows, go to a cmd prompt and enter
nslookup
> set type=MX
> stjamescollege.qld.edu.au

Server: thor.local.stjamescollege.qld.edu.au
Address: 192.168.0.2

stjamescollege.qld.edu.au canonical name =
thor.local.stjamescollege.qld.e
du.au
stjamescollege.qld.edu.au MX preference = 10, mail exchanger =
thor.local.
stjamescollege.qld.edu.au
stjamescollege.qld.edu.au nameserver =
ns.local.stjamescollege.qld.edu.au
stjamescollege.qld.edu.au nameserver =
thor.local.stjamescollege.qld.edu.a
u
>


Repeat a few times.
> stjamescollege.qld.edu.au

etc.

After a few seconds (varies from 3s to 15s) the output changes to
> stjamescollege.qld.edu.au

Server: thor.local.stjamescollege.qld.edu.au
Address: 192.168.0.2

stjamescollege.qld.edu.au canonical name =
thor.local.stjamescollege.qld.e
du.au
stjamescollege.qld.edu.au nameserver =
ns.local.stjamescollege.qld.edu.au
stjamescollege.qld.edu.au nameserver =
thor.local.stjamescollege.qld.edu.a
u
stjamescollege.qld.edu.au MX preference = 10, mail exchanger =
thor.local.
stjamescollege.qld.edu.au
>


then
> stjamescollege.qld.edu.au

Server: thor.local.stjamescollege.qld.edu.au
Address: 192.168.0.2

stjamescollege.qld.edu.au canonical name =
thor.local.stjamescollege.qld.e
du.au
stjamescollege.qld.edu.au nameserver =
ns.local.stjamescollege.qld.edu.au
stjamescollege.qld.edu.au nameserver =
thor.local.stjamescollege.qld.edu.a
u
thor.local.stjamescollege.qld.edu.au internet address = 192.168.0.2
>


No more mx records. I'm hoping that this is the cause of the sendmail
failures.

Can anyone offer a suggestion as to why tis may be occurring?

details:
Netware 6sp5
named.nlm 5.12.06
resolve.cfg:
domain local.stjamescollege.qld.edu.au
nameserver 192.168.0.2
nameserver 210.18.210.1