I have the following configuration/setup, which worked fine on a NW6.0sp5
server. I migrated to NW6.5 on new hardware and now it doesn't work.

Back in 2002 I did my one and only install of DNS/DHCP using a print out
entitled A Beginners Guide to Setting up NetWare 5.0 and 5.1 DNS and DHCP
Services by Joe Moore. It worked well enough for NW6. My all-purpose
server's IP adress is x.x.x.20. I added a secondary address of x.x.x.10 to
handle the DNS/DHCP, web server, GW web access and any other web-based apps.
My GW is set up on x.x.x.20, the default IP of the server. All of my users
that have GW Remote and my spam hardware are pointing there or to the public
IP NATed to it. This next part is probably wrong , but years ago I set up
an A record for x.x.x.20 and called it mail.mydomain.com and then created an
MX record for mail.mydomain.com.

I set up my DNS server on the secondary IP address, x.x.x.10 and created an
A record named myserver.mydomain.com. I then created an NS record for
myserver.mydomain.com. My ISP has another of our public IPs pointing to to
myserver.mydomain.com so we can hit the main page of our intranet internally
or externally (when it's working). Any request my DNS server can't handle is
passed to my ISP's DNS.

My server's ETC\host file on NW6 had the following lines:

and all this worked. I have been told that NW6 handled "multihoming"
differently and this would work in NW6, but not in NW 6.5. I cannot access
any browser-based services on my server and I think I need to start at he
beginning with a properly configured DNS setup. I have been through all the
PKIDIAG,SSLCertificate, SLP, LDAP, TCKEYGEN, etc,etc. steps and it all
appears good. I think it stems from this host file and some bad decisions
when i originally configured DNS. What is wrong with my DNS setup and what
should my hosts file and hostname file contain?