I searched the groups and came across another post regarding this same
problem, but didn't find a solution.

Here is the situation. We have 25 Novell clients on a separate subnet and
we are trying to use DHCP for SLP.

We have a BIND DNS server configured with these options:
option slp-directory-agent true,;
option slp-service-scope true "L_SCOPE,L_MASTER_SCOPE";
and a Cisco router which is configured for DHCP relay. The workstation gets
all other IP address information via DHCP, but none of the SLP info.

I checked a DHCP session with Wireshark and didn't see DHCP options 85, 86
or 87 in the parameters list. I checked the NCP traffic and also couldn't
find any reference to a request for these options.

I read in the documentation that it should be possible to use DHCP for SLP
through a DHCP relay agent.

Here are the slpinfo results. The Scope List and DA are empty.

************************************************** ***
*** Novell Client for Windows NT ***
*** Service Location Diagnostics ***
************************************************** ***

SLP Version:
SLP Start Time: 3:09:28pm 8/13/2007
Last I/O: 3:56:58pm 8/13/2007
Total Packets: Out: 178 In:
Total Bytes: Out: 17476 In:

SLP Operational Parameters Values
------------------------------- ------------
Static Scopes NO
Static Directory Agents NO
Active Discovery YES
Use Broadcast for SLP Multicast NO
SLP Maximum Transmission Unit 1400 bytes
SLP Multicast Radius 32 hops

SLP Timers Values
------------------------------------- ------------
Give Up on Requests to SAs 15 seconds
Close Idle TCP Connections 5 minutes
Cache SLP Replies 1 minutes
SLP Default Registration Lifetime 10800 seconds
Wait Before Giving Up on DA 5 seconds
Wait Before Registering on Passive DA 1-2 seconds

Scope List Source(s)
---------------------------------------- ------------

DA IP Address Source(s) State Version Local Interface Scope(s)
--------------- --------- ----- ------- ---------------
<No Directory Agents>

Local Interface 10.160.5.xxx
Operational State: UP
Operating Mode(s): MCAST
SA/UA Scopes: <unscoped>
Last I/O: 3:56:58pm 8/13/2007
Total Packets: Out: 178 In:
Total Bytes: Out: 17476 In:
Last Addr Out:
Last Addr In:

What could be the problem?
Any insight would be appreciated.

Walter Greenwood