Just a general question regarding rights.

We have several users, some might not have rights to directories that
we want to deploy from. Our goal would be to create an object (it
doesn't matter who is logged in), but the workstation would be granted
rights to install (regarding of users--do to limited contractor

We were deploying to workstations in the company and had some problems
with error 1612 (rights). So we have an object (Visio Viewer),
everyone that logs into our boxes are administrators of the box, so on
the COMMON tab, rights, we assign R/F to the VisioViewer directory.
Note that many people do not physically have rights to this directory.
We assumed by giving R/F to the object on the COMMON tab, that the
machine when we deployed the object, would have R/F to that directory.
That is not happening. No matter what boxes we check/uncheck, it still
appears to be utilizing user rights.

We purposely blocked my user for R/F to this directory and deployed the
object. It failed. As soon as we give my user rights, it works again.
We have played with RUN OPTIONS, Environment, Run Normal | Run as secure
system user, Run a unsecure system user | Distribution tab | Options |
Distribute in Workstation Security Space if Workstation Associated,
etc., and it always is appearing to utilize my user rights. We have it
installing from a drive, then we tried an object with a fully defined
path and still not luck.

Can someone tell me if this is possible or what we may be doing