I am trying to get a Zenapp to install an antivirus driver update and force
a reboot. Sometimes it works, other times it does not.

The zenapp is configure to do this;
Path to file: c:\zentemp\inoculan\drvupdi.155.exe
Parameters: /s /a /r
the /r specifys for the exe to force a reboot.
Workingdir: c:\zentemp\inoculan\
Run once: no
Force run as user: no

It copys the drvupdi.155.exe from server to that location. Copy if different.

Environment is hidden, and run as secure system user.
Identification is wait on force run and show progress.
Options is Distribute always, reboot always, and don't prompt.

Application availability checks to see that no one is signed onto the PC
and that the resulting ino_fltr.sys driver is less than this version.

I've tested the zen app on two VM machines and it works perfect.

I've got another machine which has been powered on for 9 days with no-one
ever signing on where it distributed once but hasn't ever again. The
machine never rebooted and the install never occured.

My machine shows "Distribution Success" in the logs every 2 minutes that I
was not signed onto it. However the patch never installed, nor did I ever

I have tried changing the parms so that only the .exe forces the reboot,
and I have tried so that only the Zenapp forces the reboot. But no sucess.

What am I doing wrong here? This is the first time I am trying to force a