I'm having a problem on a few workstations with an application reinstalling
itself each time the user logs in. This just started happening a week ago
when we did an upgrade. The change included moving from Novell Client 4.90
and newer to 4.91 SP2 and moving from Zenworks Agent 6.5 SP1 to Zenworks
Agent 6.5 SP2. On a couple of workstations the Novell Client keeps
installing; on others Symantec Antivirus CE Maintenance Patch 1 and
Maintenance Patch 1 Point Patch 1 keep reinstalling. My ZfD apps are set to
force run for the users. The run application box is unchecked. My
distribution rules are:

Novell Client
HKLM\software\Novell\NetWareWorkstation\CurrentVer sion
MajorVersion < 0x00000004
MinorVersion < 0x0000005B
Service Pack < 0x00000002

SAV Maintenance Patch 1
c:\program files\symanted antivirus\doscan.exe exists AND
file version c:\program files\symanted antivirus\doscan.exe = 10.1.0.394


SAV Maintenance Patch 1 Point Patch 1
c:\program files\symanted antivirus\doscan.exe exists AND
file version c:\program files\symanted antivirus\doscan.exe = 10.1.0.400


I've checked the registry and the file version on these computers and they
are up to date yet the installation runs anyway. I checked the Windows
Event Log for one of the computers having the SAV reinstall and it had a
number of references of trying to access C:\Program Files\Common
Files\Microsoft Shared\SFPCA Cache\msxml3.dll but the file was not there;
however I checked using Windows Explorer and the file is present.

Like I said this is happening to a few but not all of the workstations. I'm
at a loss to explain why. Do you have any suggestions?


Matthew