I created a NAL app to change a few registry settings for the year 2007 DST
changes. I ran the app manually via App Launcher as a power user on several
W2K workstations with out a problem so I decided to force run the app for
all of my users. I immediately started getting calls from users complaining
that they could no longer run any programs.

This did not effect all machines although I run pretty much the same image
on all PCs. There were at least 4 different models of PCs (laptop &
desktops, all Gateway) that were effected. The only workstations that were
effected were logged on during a 20 minute period when I had the app set to
force run.

What happened is that all of the file associations in HKLM\Software\Classes
from * to .gst were deleted (including .exe). If you double clicked, or
tried to run an application file in any other way, MS Windows, Open With box
poped up. Most desktop icons reverted to generic Windows icons.

I was able to export the missing portion of the registry from a working PC
and then import the file to fix the problem but I am wondering if anyone can
explain what happened.

I exported the NAL app to an AXT file but as you can see, there is very
little to it.

I am still having lingering issues that I think are associated with the
issue. Nalwin32 aborts when starting or when launching different
applications but I can't find a commonality between apps that abort NAL. I
have also had to install a few applications though again, no program is
failing on all effected PCs.

Netware servers - 4 servers that are either 5.1 Sp6 or 6.5 Sp5
Zenworks 4
Workstations are all W2K SP 4, about 30 had problem, all users are Power

Sorry for the long winded post but I figured I should get all the facts out.
Any insights would be appreciated.