I am trying to run some pre launch or pre distribution script on my app.
Please clarify some issues.
It was my understanding that running a batch file from the run before
launching window in C1 would run the script with elevated rights(system
rights) is this correct ?

I had initially tried to enter the script commands directly in the window
and it would not run.

i.e rem Script call
%*winsysdir%/mkdir "C:\program Files\Test"
error on app launch: Could not get resources...Script execution failed

I then tried to create a .bat file and call it from the window....still
would not run
i.e \\Server\Vol1\appdistro\script1.bat

This wouldn't work until i put in an "@"before the call...why?(explain pls)
i.e @\\Server\Vol1\appdistro\script1.bat
in addition i also get the error below.
error on app launch: I get an access denied on the file creation command

What do i seem to be doing wrong. Is there a specialized syntax required.

A detailed explanation and personal insight on this issue is appreciated.

Please using layman terms i.e (common terms) is sweeter