Ok I've spent several hours figuring this out and I have a fix for it,
however it's less than desirable.

Here's the background. New computers, Zen 6.5 Sp1 Win XP sp2.
Workstations register and create the workstation object but then
inventory is not present in database.

I tried rerunning the inventory process with wmsched with no luck. Full
scan didn't help either. I tried all sorts of things. Finally I tried
running dbwin32 (not a novell tool) to see what was going on.

What is happening is that it's trying to send it to a workstation object
that doesn't exist. The machine was renamed, zwsreg -unreg, and
reimported, but it's still trying to send the info to the old name.

I figured out it was (I think) getting that name from the image safe
data because that's what it says there. Why doesn't it update that when
you rename a workstation?????? Anyway. I unregistered the
workstation, ran ziswin, cleared the workstation data and quit so it
could re-create it. After that, the workstation imported.

Here's my problem. I have 40 notebooks that just came in. We loaded
one up and sent it to the provider who then using ghost loaded that
image on all of the machines. I'm sure I have other machines in the
building with a similar problem. There doesn't seem to be a way to run
ziswin with a command line paramater to clear out the data or at least
have it populate correctly that I can automate in a login script.

So I have a fix that I can do by hand.

Anyone have a better way of doing this?