we have ZenWorks 6.5 SP1a on Netware 6.5 SP3. The inventory database runs
on a Solaris 9 Server with Oracle 8i (V 8.1.7).

The problem is that sometimes (I guess when ZenWorks gets no inventory data
for 24 hours or so) the storer ends with a database error like this:
[4/4/05 10:04:18.118] ZENInv - Storer: Loading Storer test properties file
[4/4/05 10:04:18.119] ZENInv - Storer: Storer: started storing
0007E952F264_1111665240000_4.STR (3114 bytes)
[4/4/05 10:04:18.154] ZENInv - Storer: MainThread-1 position:
com.novell.zenworks.desktop.inventory.storer.Datab aseException: Io
exception: Operation interrupted
com.novell.zenworks.desktop.inventory.storer.Datab aseOperator.checkDirectoryId$(DatabaseOperator.jav a:4580)
com.novell.zenworks.desktop.inventory.storer.Datab aseOperator.initPrepareStatements(DatabaseOperator .java:844)
at com.novell.zenworks.desktop.inventory.storer.Parse .init(Parse.java:477)
com.novell.zenworks.desktop.inventory.storer.Parse .parse(Parse.java:3719)
com.novell.zenworks.desktop.inventory.storer.MainT hread.run(MainThread.java:966)

[4/4/05 10:04:18.155] ZENInv - Status Reporting: Messages are written into
XML file for DN=CN=Inventory Service_xxx-xx.OU=Admin.O=xxxxxx
[4/4/05 10:04:18.178] ZENInv - Status Reporting: Number of records to add
are: 1 for DN=CN=Inventory Service_xxx-xx.OU=Admin.O=xxxxxx
[4/4/05 10:04:18.196] ZENInv - Status Reporting: Adding record 0 for
DN=CN=Inventory Service_xxx-xx.OU=Admin.O=xxxxxx
[4/4/05 10:04:18.248] ZENInv - Status Reporting: Number of modified records
are: 0 for DN=CN=Inventory Service_xxx-xx.OU=Admin.O=xxxxxx
[4/4/05 10:04:18.248] ZENInv - Storer: MainThread-2 position:

We don't have a clue what went wrong. After restarting the inventory
service storer starts storing again with no errors.
Hope anyone can help us.

- Manfred -