The import process from the ScanDir directory is very slow and seems to
keep stopping. It gous thru a few files at a time and then waits 4-5 mins
for one file, but the number it goes thru is variable (1-10), and the
files size is too, also not dependant on the number of files for that
workstation. The log file has the following lines when it goes slow:

[2/16/06 16:57:44.614] ZENInv - Selector: Parsing strFileSystemIdentifier
[2/16/06 16:57:44.614] ZENInv - Selector: Entering isInventoryScannerValid
()
[2/16/06 16:57:44.614] ZENInv - Selector: isFile30SP1EP1STR Confirms this
file is NOT a 30SP1EP1STR
[2/16/06 16:57:44.614] ZENInv - Selector: isFile30SP1EP1STR Confirms this
file is NOT a 30SP1EP1STR
[2/16/06 16:57:44.614] ZENInv - Selector: Updating WSDN To SynchService
HashTable
[2/16/06 16:57:44.614] ZENInv - Inventory Sync Service: SynchTable Exists
[2/16/06 16:57:44.614] ZENInv - Inventory Sync Service: Entry Already
Present.Will not update SynchTable
[2/16/06 16:57:44.614] ZENInv - Selector: isFile30SP1EP1STR Confirms this
file is NOT a 30SP1EP1STR
[2/16/06 16:57:44.614] ZENInv - Selector: Reading NDS ScanNumber
[2/16/06 16:57:44.677] ZENInv - Storer: Products=117 Sw_Times = 117 117 0
0 54 94 0 0 152 117 6 1 TotalTime=370
[2/16/06 16:57:45.397] ZENInv - Storer: FileCacheHits=493 : 494
[2/16/06 16:57:46.754] ZENInv - Storer: time for getting unique object: 91
[2/16/06 16:57:46.770] ZENInv - Storer: adding status message
[2/16/06 16:59:36.846] ZENInv - Selector: NDS ScanNumber Read -1
[2/16/06 16:59:36.847] ZENInv - Selector: NDS attrModificationTime Read -1
[2/16/06 16:59:36.847] ZENInv - Selector: Setting Sequence Number to -1
because deleteFlag is TRUE
[2/16/06 16:59:36.847] ZENInv - Selector: Modifying Attribute seqNo with -1
[2/16/06 16:59:36.847] ZENInv - Selector: Entering forceFullScanFlag Loop
[2/16/06 16:59:36.847] ZENInv - Selector: Forcing FULL Scan in NDS (-1)
[2/16/06 17:00:00.000] ZENInv - Sync Scheduler: Schedule Expired
[2/16/06 17:01:28.991] ZENInv - Selector: Unable to update the sequence
Number
[2/16/06 17:01:28.991] ZENInv - Status Reporting: Number of records to add
are: 0 for DN=CN=HCC032423 00:12:3F:FB:29:8D.OU=SHARED
CARE.OU=OPERATIONS.OU=CSF.OU=APSLEY.O=HCC
[2/16/06 17:01:28.992] ZENInv - Selector: Deleting
APSZENSYS01:\ZENworks\Inv\ScanDir\000BDB4D66E6_113 8033261000_11.STR
[2/16/06 17:01:28.992] ZENInv - Selector: Unlocked SelectorXMLAgent
FileAPSZENSYS01:\ZENworks\Inv\ScanDir\000BDB4D66E6 _1138033261000_11.STR
[2/16/06 17:01:28.992] ZENInv - Selector: Unlocked ConverterSelector
FileAPSZENSYS01:\ZENworks\Inv\ScanDir\000BDB4D66E6 _1138033261000_11.STR
[2/16/06 17:01:28.992] ZENInv - Selector: Unlocked SynchServiceSelector
FileAPSZENSYS01:\ZENworks\Inv\ScanDir\000BDB4D66E6 _1138033261000_11.STR
[2/16/06 17:01:28.992] ZENInv - Selector: Selector Yielding for ms0

deleteFlag is TRUE does appear occasionally throughout the logs with no
delay around it, but every delay does contain the lines around it.

Can someone please explain what is going on and how to stopit going so
slow.

Thanks Drew