I can navigate to Tools->Zenworks Inventory->Configure Database, browse to
and select {server_name}_invDatabase. However, when I click OK the mouse
pointer just turns into an hourglass. The window won’t close and accept
the change. You end up clicking Cancel with the hourglass to close the
window. You can right click on the {server_name}_invDatabase object in
eDir and choose Zenworks Inventory->Configure DB but when you attempt to do
a query or something a window pops up prompting you to first configure your

Netware 6.5 SP5.
ConsoleOne 1.3.6e with Zenworks 6.5.2 snapins (after upgrade, see below)
We were running Zenworks for Desktops 4 until I upgraded to Zenworks 6.5
SP1 about a year to year and a half ago. Some time after that the
Inventory functionality stopped. I’m now trying to fix it.

1. I first applied Support Pack 2 for Zenworks 6.5. That didn’t fix my

2. I then tried reinstalling the Inventory Service off the Zenworks 6.5
with SP1 CD, starting the Inventory service, and then reapplying SP2. That
didn’t fix it.

3. I have followed the steps in Novell TID # 10097151. I actually had been
wondering which object was the correct one, if it was “Inventory
Service_{server_name}” or “{server_name}_ZenInvService.” After following
these steps I am seeing computers getting inventoried on the Inventory
Service console screen. That wasn’t happening before. So this fixed one
of my problems but not all of them.

4. I then followed the steps in Novell TID #10097366. I confirmed the
usernames were set as shown and retyped the passwords. I even restarted
the Sybase (ASA) and Zen Inventory services at the console but that didn’t
fix it.

5. I found this thread
in which other users were dealing with the same problem. I found an older
copy of InventorySnapins.jar as specified and tried it but that didn’t fix it.

What can I try next? I really want to use Zenworks to hunt for old apps on
my network that we’re not using anymore.

And in a side note, where *do* you configure Zenworks to scan a workstation
for applications? The software scan tab of the workstation inventory
policy has a footnote saying these settings only apply to ZfD 3.2, 4, and
4.01. I checked the ZfD 6.5 SP2 manual and it says about the same thing
verbatim. However, neither one includes a helpful sentence telling you
*where* to set this if you are using Zenworks 6.5 or even referring to a
different chapter or section of the manual. Does Zenworks just assume that
if you want to inventory the hardware that you want the software
inventoried as well and just do it automatically?

Thanks in advance for your help!