NetWare 6.5 SP6
ZfD 7.0.1 SP1 (hotpatch 2)

I want to remove any duplicate workstations from the Inventory database (Sybase),
but hre routine cannot connect to the database.

I first stop the Inventory Services (stopser *).
Then I run the DUPREMOVE.NCF, but it fails to connect to the Inventory database,
with the following statements showing in the Dupremove Utility Screen:

Trying to connect to the database -> mw_dba
jdbc:sybase:Tds: ONNECT_VERSION=4
java.sql.SQLException: JZ006: Caught IOException: Connection refused
at com.sybase.jdbc.ErrorMessage.raiseError(ErrorMessa
at com.sybase.tds.Tds.login(
at com.sybase.jdbc.SybConnection.tryLogin(SybConnecti
at com.sybase.jdbc.SybConnection.regularConnect(SybCo
at com.sybase.jdbc.SybConnection.<init>(SybConnection .java)
at com.sybase.jdbc.SybDriver.connect(
at java.sql.DriverManager.getConnection(DriverManager .java:512)
at java.sql.DriverManager.getConnection(DriverManager .java:140)
at com.novell.zenworks.desktop.inventory.storer.Datab aseOperator.createConnection( :830)
at com.novell.zenworks.desktop.inventory.storer.Datab aseOperator.<init>(
at com.novell.zenworks.desktop.inventory.storer.Datab aseOperator.main(Da
Could not connect to database.

At the same time, this message appears in the NetWare Logger Screen:

Exception in thread "main" java.lang.NoClassDefFoundError:

The only effective lines in the DUPREMOVE.NCF are like this:

rem typical use:
rem In Case of Sybase
java -Djava.compiler= com.novell.zenworks.desktop.inventory.storer.Datab aseOperator -host=
-remwsdup=* -remwspattern=CN=% -dbtype=0

rem After running this utility take the list of workstations which has been cleaned up for triggering a fullscan on these Workstation objects.
java -ns -sn"ZENworks Inventory Dupremove utility" -neh -mx128m -classpath $tmppath;"$classpath" -Djava.compiler= com.novell.zenworks.desktop.inventory.storer.Datab aseOperator %1 %2 %3 %4 %5 %6

After failing to connect, the Dupremove Java process runs forever, and has to be killed by entering (example): java -kill668

Why can't the Dupremove process connect to the Inventory database?
I have also tried using a DNS name (FQDN) instead of the IP-address, without any luck.
We have only one single Inventory server.

- Erik