I turned on MSI logging and pasted links to the logs from a Windows98 and WindowsXP boxes.
Thanks
Mike

http://www.ontario.k12.or.us/ftp/msi_logs/WinXP_MSI.txt

http://www.ontario.k12.or.us/ftp/msi_logs/Win98_MSI.txt


Brief history:
Hello,
We have upgraded from ZfD4.0.1 to ZfD6.5. We have Netware 6 sp5 and Netware 6.5 sp2 Servers with XPsp1 workstations w/Novell Client 4.9sp1a and Zfd Agent 4.0.1.4.
Whenever I upgrade the ZFD Agent 4.0.1.4 on one of the XP boxes either manually or by Zen (force cache delivered MSI), There are three options that are not upgraded/installed: (Application Management, Remote Managementw/Mirror >Driver, and Workstation Imaging). Even if I rerun the Zen MSI the components are not installed. I have to run the install a >second time manually and select the missing compontents. Then it installs all the components.
Also if I run it manually the first time and reselect the selected components it will install fully the first run.

ZEN MSI Properties:
ADDLOCAL=ApplicationLauncher
ADDLOCAL=WorkstationManager
ADDLOCAL=RemoteManager
ADDLOCAL=MirrorDriver
ADDLOCAL=Imaging
ADDLOCAL=Inventory
STARTUP_APPEXPLORER=1
NAL_SINGLE_TREE=1
ZENWORKS_TREE=SD8C_TREE
REINSTALLMODE=vamus (this line was added later, did no solve problem)


> >>> Jared L Jennings< jaredljenningsNO@SPAMmyrealbox.com > 8/28/2004

> 9:58:22 PM >>> Well it looks like reinstall=all is broken. Maybe I
> can come up with a different method.
> http://support.novell.com/cgi-bin/se...?/10094052.htm
>
> --


Would you be able to enable msi logging and then rerun the install so
that we can hopefully capture when it does not upgrade the other
components?
http://support.microsoft.com/default...b;en-us;314852

--
Jared L Jennings
Novell Support Forums SysOp
Systems Analyst with Data Technique, INC.
ICQ# 27902780
Using XanaNews 1.16.4.2