I hit this problem after upgrading directly from ZfD 4.01 to ZfD 7 and
noticed many complaints, but no solutions. Here is what I discovered . . .

After upgrading to ZfD 7, ws auto-import was no longer working for anyone
outside the import server's context. We used a policy that placed the
created workstation in the user's own context, which worked fine in 4.01
(IR4, I think). Every server and user was two levels down from root, but in
context by location like this . . .


The import server was in W.WEST, but every time it tried to import a
workstation from another context (A.WEST, B.WEST, etc.) it merely reported
"Could not locate target container". Eventually, I discovered a
successfully imported workstation from a little used context (ie Z.WEST).
The common thread was that the Z.WEST was part of the same eDir parition
(Root) as W.WEST where the import server resided. The import server held RW
replicas of every eDir partition and held Admin rights to the entire tree
(troubleshooting steps). However, it could not create workstations on
different eDir partition from its own.

Once I merged a test partition (A.WEST) into the root partition with the
import server, workstations started magically importing. I then eventually
removed all partitions so the entire tree was a single eDir partition (it's
small enough I could do that easily). Voila. No more "target container"
messages and lots of successfully imported workstations!

Kevin Leek
Kevin dot Leek at Fiserv dot com
CNA, MCSE, CCNA, Die hard Dodger fan