First problem - I'm not sure which forum under Zenworks Desktop management
to post this to. Does import and removal fall under:
Application Launcher?
Install and Setup?
Management Agent?
or Remote Control?

So, sorry for the crossposting.

The problem is that I have a Zen65 test server and can't get automatic or
manual workstation import to work.
The Facts:
1. server policy set up as General, associated to server and appropriate
workstation container. Policy set to import on 1st login to selected
workstation container. No group memberships or anything fancy set up.
2. import service is verified to be active on server
3. workstation is running 4.90 sp2 client as well as Desktop Agent (is this
necessary? - I found the documentation unclear)
4. workstation can ping zenwsimport fine

Problem: nothing is getting logged to zenwsimp.log or zenwsrem.log on the
server, nothing is getting logged to wsreg32.log on the workstation, and
manually trying to run zwsreg.exe results in this error:
Zenwsreg returned the following error code: 2

I've tried blowing away the policy (always stopping the service first
before making any policy changes), recreating it, reinstalling the client
on the workstation, reinstalling the Desktop Agent. The only thing I have
not tried is reinstalling Zenworks all together. Any suggestions are welcome.