Had something strange happen today, so I'll document it here.

One of my pushed shortcuts (and of course it was the one that everyone
in the company uses) stopped working today - but only for some users.

A very simple app: a "run" line of acrord32.exe and a parameters line
pointing to a pdf file on a network location. Not much room for
problems there, but it was throwing an ID 3 error: invalid path.

Nothing seemed out of place. Affected users did indeed have
acrord32.exe installed and they had access to the network location.

In an effort to make the app more exact, I changed the "run" to
%*ProgramFiles%\Adobe\Acrobat 7.0\Reader\AcroRd32.exe - both with and
without quotation marks. Both efforts got an ID 2 error: can't get
needed resource.

In desperation, I changed the "run" line to: C:\Program
Files\Adobe\Acrobat 7.0\Reader\AcroRd32.exe - without quotation marks.
Which worked, contrary to what I thought I knew about enclosing
filenames/paths with embedded spaces in quotation marks.

For the sake of experimenting, I made a new app with a "run" line of:
%*ProgramFiles%\Adobe\Acrobat 7.0\Reader\AcroRd32.exe - no quotes - and
assigned it to myself. It worked fine too.

Everyone seems to be working now, so I'm not too excited about it, but
there for a while things were looking grim.

We're running 7.0 (no sp) on Win2K. Middle tier with no clients.

Anyone seen anything like this?