Hi, I hope someone is able to help with this.

We recently upgraded our main workstation image from office xp to office
2003. Now when ever a pupil (I work in a school) user is used,
explorer.exe will cause an application popup when you try to shutdown. The
error is as follows:

"Explorer.EXE Application Error
The instruction at "0x00030006" referenced memory at "0x00030006". The
memory could not be "written".
Click on OK to terminate the program
Click on CANCEL to debug the program"

The memory address varies from crash to crash, but in one single instance,
the two values reported are always the same as if the instruction is
trying to overwrite itself?

Our setup is:
Servers: Netware 6.5 SP5
Zenworks: 7 SP1 HP6
Workstations: Windows XP SP2, up to date with critical updates
Netware Client 4.91 SP4
Novell Application Launcher
Files: ZenAppWs.dll -
NalUI.dll -
NalShell.dll -
ZenLite.dll -
NalNTSrv.exe -
NalAgent.exe -
NalWin.exe -
NalView.exe -

This error only occurs when Application Explorer is running, it is run
automatically via a workstation policy on user login. If we run
Application Window instead the problem goes away.

The problem does not seem to occur when we log in our admin user, without
DLU and authenticate to windows with the administrator account.

The only thing logged in the Event Viewer on the workstation is an
information post in the System log that has recorded what the application
popup said. If I send that information to Microsoft's Help & Support
Centre it says:

"The program could not load a driver because the program user doesn't have
sufficient privileges to access the driver or because the driver is
missing or corrupt.

To correct this problem:
- Ensure that the program user has sufficient privileges to access the
directory in which the driver is installed.
- Reinstall the program to restore the driver to the correct location."

Things I have tried without success:
- Removing group policies associated to our users.
- Removing the mandatory profile associated to our users.
- Creating Dynamic Local Users with Administrative rights.
- Disabling DLU, creating a local account for a user with administrative
- Upgrading to the latest ZFD hotpatch (6) in the hope that the problem
was the same as described in TID 3267560
- removing and reinstalling the netware client
- removing and reinstalling the zfdagent
- repairing the installation of windows in case of corrupt drivers
- installing the image on another machine of the same model to eliminate
potential hardware issues (dell optiplex gx520) - had the same problem.
- manually running application explorer rather than via a policy.
- update office 2003
- tried but failed to find out what driver is residing at the memory
address in question.

After all this, the only way I can solve the issue is to run NalWin.exe
instead of NalView.exe , but we use the Start Menu icons that Application
Explorer provides, and would like to keep using it.

It is strange the the problem doesn't occur for our admin user without
DLU. But I have discounted DLU, Group Policies and the Mandatory Profile,
and have tried giving the users local administrative privileges.

I've run out of ideas now, so I was hoping that someone here might be able
to come up with some.

Thanks in advance.