We have been using PXE and imaging for a few months by now running on
NW65SP3 + DHCP + Zenworks 7 all on the same server, clients are Dell
OptiPlex GX620 ( but all with CDROM drives only, no DVD :). Everything
worked *perfect*, always - even multicasting.

Now I am testing Zenworks 7 SP1 on OES SP2 SLES9 ( all latest patches
installed ) in the same tree, with DHCP still running on NW65 ( not that it
matters here I believe ), PDHCP and the rest is on SLES. After a bit of
fiddling ( I was surprised to see Zenworks config files being left "as is"
after installation, so manually filled in a few IP addresses there, then
restarted services ) it started to work - even multicasting.

*THE PROBLEM* 3 our of 26 machines did not make it to the final 'imaging'
screen during a multicast session - PXE would work, OS starts loading, light
blue Novell screen comes up - and then it switches to SUSE GUI with the menu
with options to install Linux, exit/reboot etc. One machine actually had a
RED message simply saying "Linux has crashed, sorry :(" ( I think it was a
bit longer but that is pretty much an exact wording ).

Upon restart all three machines joined the session and imaging was
successfully completed ! Still, I do not like the perspective of almost 10%
of clients crashing then having to restart them manually. Both servers are
plugged into the same switch, SLES server may be not as gutsy as NW65 but
surely it can handle 25 clients PXE booting from it.

I found this posted earlier, I have seen this before but I do not think it
applies in my case .. who knows, though :

When booting from the SuSE 6.5sp2 boot.iso on a Dell Optiplex GX620, the
SuSE imaging main menu never shows up. As a result, the SuSE generic
character-mode GUI is presented with options to install SuSE, eject CD, etc.
Essentially, it's very broken.

The issue was isolated to only those GX620's with the Philips DVD drive.
Any GX620 having the generic HL-Data DVD drive worked flawlessly.

Novell and Dell have worked together on the support call that I opened a
while back on this issue. TID10100469 is the result. It's a work in
progress. I would reckon that we'll see a patch for this sooner rather than
later. Meanwhile, the workaround we've used has been to plug an external
USB CD or DVD drive and unplug the internal one. Then the same ZFD 6.5.2
boot.iso works fine once again."

Any ideas what could that be about ? I am going to change the logging level
and watch the log file(s).