Hi All,

I have searched for threads concerning this with no apparent and
correct solution.

Cisco 2950G switches with static speed/duplex settings
VLAN's are in use but we do not use spanning-tree on our network.
Port-security enabled with 1 mac address allowed.

Upon approximately 10 power cycles of a PC connected to the switch and
configured to PXE boot using Zen 7.0.1 and 7.1 (same?) 1 of these
occassions it will give the error:

Heap:Dispose Fail
ERROR: no response from Port map service

At this point the port is error disabled and is flagged as a security
violation. Upon checking the syslog of the cisco switch it is plain to
see that the port is receiving a different mac-address to that of the
LAN card in the PC. The vendor ID is always that of Schneider and Koch
beginning with 0000.5a.

Other threads supposed that the fix was to configure the switchports to
have portfast enabled. However, we have portfast enabled on our ports
(and we have tried it with it disabled too with the exact same result)
and strictly speaking you only need that enabled to circumvent the
delay in the port moving into a forwarding state if you are using
spanning-tree on your network.

The hardware of the PC are mostly Viglen based and Asus motherboards
with built in LAN card. A BIOS update has had no effect.

What is puzzling is that 80% of the time the workstation works without
a problem. But approximately 1 in 8 power cycles it has the Heap error
and causes a switchport security violation. I have checked speed/duplex
settings match and tried different configurations on the switchport. I
think the error is on the server. If the portmap service was not
started surely it would never work ? Additionally the server does have
backup exec client installed to backup the server but from what I read
it uses tcp port 10000. Why does the portmap service on the server use
pop3 port 110 ?

Any help appreciated.