Got a copy of the newest ZEN 6.5 Imaging CD (supposedly almost the same
as ZEN 7's) which runs a stripped-down version of SLES 9 SP2.

I am not really Linux-savvy.

I have a number of custom scripts I wrote which worked with the older
Imaging CDs.

In the past, I modified environment.s and added some custom environment
variables, including one that overrides IMGCMD so that it runs our
imaging menu instead of the default boot CD stuff.

As you know, the boot CD has changed a lot with the new version.

I was able to get just about everything ported over to the new boot CD
with one REALLY annoying exception: I cannot for the life of me figure
out how to get both MANUL and IMAGING modes to work consistently.

In IMAGING/Automatic Mode (where is defaults to performing the command
specified in the IMGCMD env variable), it runs my shell script file,
which loads a PDMenu menu. Each PDMenu entry loads its own shell script
for restoring images, opening a BASH shell, etc. Everythign works fine.

Now, if I choose Manual Mode instead, and then run the IMGCMF from the
BASH shell, the shell scripts do not work properly.

Here is the thing:

I tried to make all shell scripts consistent with each other. I made
them all executable, they follow the same format, etc.

I made it so that all scripts were run like this: "sh <script>". But it
would only work in either Manual or Automatic mode (but not both). I
then modified every script so that it they were called like this:
"./<script file>". Same thing as before, but now if it worked in
Automatic Mode it now only works in Manual Mode, and vice versa.

Basically, I cannot get shell scripting work work consistently in both
AUtomatic and Manual Modes.

Anyone have any idea how to troubleshoot this anymore? I've wasted a
few days on this.