I have seen previous posts relating to the above-named Dells and am also
having similar problems. I also posted a reply in
bruce.forbes@oopb.on.ca's message dated December 16, 2005 but am posting
the same response here. I don't think anyone would go back to that date
and post a reply to my questions.

Here is what I posted originally:
Is there a solution? I am having the same problems with the same Dell
Latitude D810 as well as with Dell Optiplex GX280 computers. We are
using ZEN 7 and were able to successfully image an IBM ThinkCentre with
the same Broadcom 5700 cards without having to update anything. I tried
updating the BIOS on the Dells but with no success. What happens on the
Dells is after the ZEN Maintenance menu appears and Start Maintenance
Mode ZEN Imaging is selected, Linux starts, Sending DHCP request, then a
message that DHCP configuration failed, then it sends DHCP request to
eth0, then another message that it could not find the ZENworks
Installation Source so it activates the manual setup program. In there,
under show loaded modules, I notice that it is using the Broadcom Tigon3
Ethernet driver instead of the Broadcom 5700 driver, but I am not
familiar with Linux to change the driver to the bcm5700. I tried
unloading the Broadcom Tigon3 Ethernet and loaded the bcm5700 but I still
ended with the same results.